Skip to content

手動安裝 iOS 模擬器到 Xcode

由於 Xcode 下載速度慢,或者新版 Xcode 無法直接下載太舊的 iOS 模擬器等問題,我們有時候會需要手動安裝 iOS 模擬器檔案。這篇教學將會簡單說明操作方式。

首先,我們先去下載想要的 iOS 模擬器版本的 dmg,這個網站裡面有很多版本的列表,可以選擇你想要的版本來下載。

網路上的教學大部分都是教你丟到 Xcode 下載路徑的 cache 裡面方便快速安裝,但是對於如果想要下載舊版本模擬器的情況來說,由於 Xcode 裡面就沒有舊版本模擬器的選項了,所以用這些教學教的方式,是無法自動幫你裝好檔案的。舉例來說,我想在 Xcode 10.3 裡面安裝 iOS 8.4 的模擬器,但 Xcode 10.3 裡面可以選的最低版本為 10.3.1 的模擬器,根本無法自動安裝 iOS 8.4。

所以,我們從上面的連結中,先手動下載 iOS 8.4 模擬器的 dmg,並且開啟後發現他是一個 pkg 安裝檔。這時候請不要安裝,先去下載 Pacifist 這個軟體,之後把 .pkg 檔案用 Pacifist 開啟。

接著,我們要建立放置檔案的資料夾,以這個範例來說,路徑是 /Library/Developer/CoreSimulator/Profiles/Runtimes/,在這裡面我們隨便建立一個資料夾,名稱隨便取名。之後在 Pacifist 裡面,選擇「Contents」資料夾,然後選擇「Extract To…」解壓縮到我們剛剛建立的資料夾當中。如果詢問是否使用管理員權限,則選擇「是」。

解壓縮完成之後,把我們剛剛亂取名的資料夾改名為「iOS 8.4.simruntime」,之後重開 Xcode 跟 iOS Simulator,這樣就可以了!

發佈於macOS 教學開發技巧

目前沒有留言

發表迴響