Skip to content

亂搞 – 在 macOS 10.13 High Sierra 安裝 Xcode 10.3

因為某種原因,我的備用機不想升級到 macOS 10.14 以上,但因為要開發的關係,想盡可能的使用最新版的 Xcode。無奈 Xcode 10.1 是最後支援 High Sierra 的版本,因此研究了一下之後找到了亂搞強制安裝的方法。

基本上本教學是參考這篇文章的,但因為我個人懶惰的關係,增加了一些亂搞成分。

首先,去 Apple 開發者官網下載 Xcode 10.3,然後放到 /Applications 裡面。下載完之後會發現無法開啟,這是非常正常的現象。接著你要準備一個可以開啟 plist 檔案的編輯器,我個人推薦用這個,但是 Sublime 跟 VSCode 應該也有可以開 binary plist 的外掛,或者 BBEdit 試用版也可以。

打開 /Applications/Xcode.app/Info.plist,把 LSMinimumSystemVersion 改成 10.13,再打開 /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app/Contents/,重複以上動作。

接下來,原文教學說要使用 Xcode 10.1 的 xcodebuild 替換掉 Xcode 10.3 的 xcodebuild,但這邊我開始懶惰了,不想花時間下載。所以研究了一下發現是跟上面的原理一樣,改版本號即可。

使用 Hex Fiend 打開 /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild,搜尋 DVTMinimumSystemVersion,後面有個 10.14 的地方換成 10.13,存檔。但因為這樣會破壞 codesign,所以我們直接移除 codesign,終端機輸入 codesign --remove-signature /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild,再輸入 sudo /Applications/Xcode.app/Contents/Developer/usr/bin/xcodebuild -license,按照畫面提示作,跑完之後就可以打開 Xcode 了。測試編譯跟跑模擬器都可以正常使用。

 

結論:亂搞跟寫文章的時間比下載 Xcode 10.1 還久。

附註:Xcode 11 需要 10.14 的 Framework,無法用此方法。

發佈於技術研究開發技巧

目前沒有留言

發表迴響